Version Control with P4Eclipse

Oct 06, 2011

Eclipse is a very popular IDE for Java developers as well as developers who develop in dynamics languages like JavaScript, Ruby, PHP, and Python.  In order to version-control with Perforce, a Perforce plug-in needs to be installed in Eclipse. The Perforce plug-in is aptly named P4Eclipse.

In a nutshell, the installation of P4Eclipse is divided into three steps.

First, you will need to install Eclipse. Most likely, you have it installed already. If you have not, it is as simple as downloading the compressed file from the Eclipse website and then decompress the downloaded file to a directory of your choice.

Once you have Eclipse installed, double-click on the Eclipse binary to start it.  When it asks for the location of the Eclipse workspace, choose a location different than your Perforce workspace. As for the reason in separating Eclipse and Perforce workspaces, please consult the KB article: Eclipse vs. Perforce Workspaces for the details.

Second, an installation of the Perforce plug-in is needed.  If you have an older version of P4Eclipse, you will need to uninstall it beforehand. Otherwise, choose Help => Install New Software in Eclipse and then copy and paste the URL,

http://www.perforce.com/downloads/http/p4-eclipse/install/3.6

to the Location box. Check the needed components and then Next...=>Finish.

Third, P4Eclipse needs to be configured.  This normally pertains to setting preferences and enabling label decorations.  This is illustrated in the KB article: Getting Started with Eclipse and P4Eclipse in complete detail.

smoon's picture
About the author
Stephen Moon is a QA Engineer at Perforce.
See all posts by