Perforce User’s Guide
2014.3

January 2015

Copyright © 1999-2015 Perforce Software.

All rights reserved.

Perforce software and documentation is available from http://www.perforce.com/. You can download and use Perforce programs, but you can not sell or redistribute them. You can download, print, copy, edit, and redistribute the documentation, but you can not sell it, or sell any documentation derived from it. You can not modify or attempt to reverse engineer the programs.

This product is subject to U.S. export control laws and regulations including, but not limited to, the U.S. Export Administration Regulations, the International Traffic in Arms Regulation requirements, and all applicable end-use, end-user and destination restrictions. Licensee shall not permit, directly or indirectly, use of any Perforce technology in or by any U.S. embargoed country or otherwise in violation of any U.S. export control laws and regulations.

Perforce programs and documents are available from our Web site as is. No warranty or support is provided. Warranties and support, along with higher capacity servers, are sold by Perforce Software.

Perforce Software assumes no responsibility or liability for any errors or inaccuracies that might appear in this book. By downloading and using our programs and documents you agree to these terms.

Perforce and Inter-File Branching are trademarks of Perforce Software.

All other brands or product names are trademarks or registered trademarks of their respective companies or organizations.

Any additional software included within Perforce software is listed in License Statements on page 11.
Table of Contents

About This Manual ................................................................................................................ v

Chapter 1 Administering Perforce Using P4Admin ............................................................ 1

Home Page .......................................................................................................................... 1
Server Connections ........................................................................................................ 1
Managing Depots ........................................................................................................... 1
Managing Users and Groups ......................................................................................... 2
Managing Permissions .................................................................................................... 3
  View Permissions ........................................................................................................ 3
  Edit the Protections Table ......................................................................................... 4
Configuring Administration Tool Preferences ........................................................... 5
  Connections ................................................................................................................ 5
  Logging ....................................................................................................................... 6
  Display ....................................................................................................................... 6
  Files .......................................................................................................................... 6
  Behavior ..................................................................................................................... 6
  Tools .......................................................................................................................... 7
  Editor ......................................................................................................................... 8
  Diff ........................................................................................................................... 8
  Applets ...................................................................................................................... 9

License Statements ............................................................................................................. 11
About This Manual

This guide tells you how to use P4Admin, the Perforce graphical administration tool. It is intended for anyone using P4Admin to perform basic Perforce Server administrative tasks. Access to the complete set of administrative tools requires P4, the Perforce Command-line Client.

Other useful resources include:

- *Perforce System Administrator’s Guide*:
  

- *P4V User’s Guide*:
  

- The complete Perforce documentation library:
  
  http://www.perforce.com/documentation

- Video tutorials:
  
  http://www.perforce.com/resources/tutorials

For information about consulting and technical support, see these web portals:

- Consulting
  
  http://www.perforce.com/support-services/consulting-overview

- Technical Support
  
  http://www.perforce.com/support-services

We want your feedback! Please send any comments or corrections to <manual@perforce.com>.
Chapter 1  Administering Perforce Using P4Admin

P4Admin provides a graphical user interface for performing basic Perforce administration tasks. This chapter discusses the following topics:

- “Home Page” on page 1
- “Server Connections” on page 1
- “Managing Depots” on page 1
- “Managing Users and Groups” on page 2
- “Managing Permissions” on page 3
- “Configuring Administration Tool Preferences” on page 5

To access P4Admin from within P4V, go to Tools > Administration.

Home Page

The Administration home page enables users with super and admin permissions to view and use the following:

- **Server information**: displays details about the server to which you are connected.
- **Disk space usage**: displays details about server disk space usage.
- **Security level**: displays authentication level required by users who access the server.
- **Account management shortcuts**: displays links to common tasks.
- **User licenses**: displays details about license count and expiration.
- **Inactive users**: displays details about users who have not accessed their account in the period of time you specify.

Server Connections

To administer a server, you must first connect to it as a user that has been granted superuser privilege for the server. (If your user does not have superuser privilege, you can still administer users and groups, but cannot manage permissions or define depots.)

To connect to a server, choose Connections > Open Connection... Specify the desired settings and click OK. To administer a server, activate the connection by clicking its entry in the Connections pane. To remove a connection, context-click it and choose Close Connection.

The Administration Tool retains all of the connections that you define, so you do not need to reenter them the next time you launch the tool.

Managing Depots

If you have super user permission for the Perforce Server instance to which you are connected, you can manage the depots that it contains. Specifically, you can:
Chapter 1. Administering Perforce Using P4Admin

• Display details about a depot
• Create, edit, or delete depots
• Obliterate files from a depot

Warning
Obliterate with extreme caution. Obliteration permanently removes all traces of the specified files from the Perforce server, including revision records and metadata (such as references in labels and client workspace specifications). Files in client workspaces are left untouched, but are no longer recognized as being under Perforce control.

Managing Users and Groups

All users can display lists of users and groups using the Administration Tool, but only users with admin or super permissions can make changes. For details about access levels, refer to the Perforce System Administrator’s Guide.

To view the users defined for the server to which you are connected, choose Tools > Administration and click the Users & Groups tab.

To display details about a user, click the desired user specification. The details about that user are displayed at the bottom of the Users tab.

To create a user:

1. Choose Tools > Administration. The Administration Tool is displayed.
2. Choose File > New... > User...
   The User dialog is displayed.
3. Enter user information as follows. Click OK after making your entries.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User</td>
<td>The Perforce user name.</td>
</tr>
<tr>
<td>Password</td>
<td>The password (if any) required for the user to connect to the server.</td>
</tr>
<tr>
<td>Email</td>
<td>The user’s email address.</td>
</tr>
<tr>
<td>Full name</td>
<td>The user’s real name.</td>
</tr>
<tr>
<td>Job view</td>
<td>(Optional) Criteria specifying which jobs are automatically included on any new changelists created by the user. Example: User=bruno Status=open. For details, refer to the description of the p4 jobs command -e flag in the Perforce Command Reference.</td>
</tr>
<tr>
<td>Reviews</td>
<td>Files of interest to the user, specified using depot syntax. When changelists that affect</td>
</tr>
</tbody>
</table>
the file are submitted, the user receives email notification of the change. Note that you can also specify files of interest by clicking the Reviews tab.

Groups

Groups to which the user belongs. To add the user to a group, enter the name of the group in the Group field and click Add, or click Browse, select the group, and click OK.

To change your password: choose Administration > Change Password....

To display the groups to which a user belongs, expand the user in the Users pane. To display the users in a group, expand the group in the Groups pane.

To edit a user or group, context-click the user or group you want to edit and choose Edit.

To see the areas of the depot tree to which a user has access, context-click the user, and choose Show Permissions. The Permissions tab is displayed, with the selected user highlighted.

To add a user to a group, drag the user from the Users pane to the desired group. To remove a user from a group, context-click the user in the group and choose Remove.

To edit the groups to which a user belongs:

1. Context-click the user and choose Edit User.
   
   The User dialog is displayed.

2. Edit the list displayed in the Group membership field.

Managing Permissions

For details about how permissions work within Perforce, see the Perforce System Administrator’s Guide.

View Permissions

To display the files and folders to which a user has access, click the desired user on the Users tab.

To display the files and folders to which users in a group have access, click the desired group on the Groups tab.

To display the groups and users that have access to a file or folder, click the file or folder in the Depot Tree tab.

To see which lines of the protections table control access to a user, group, or area of the depot, click the user, group or folder of interest. The corresponding line in the protections table is highlighted. (If a user or group is neither granted nor denied access to a path by means of any entries in the protections table, the depot path displays "no access" and the "granted to" field is blank.)

To filter out lines in the right-hand pane, use the Access Level sliders to set the lowest and highest levels. The areas of the depot associated with the highlighted range of access values are displayed.
To see only those permissions that apply to a user's workstation, enter the IP address of the workstation in the **Host IP filter** field. For example, permissions lines with a host value of `192.168.*.*` and `192.168.1.*` both apply to a workstation at `192.168.1.10`.

To show files in the Depot Tree, click **Show files**.

### Edit the Protections Table

The protections table is displayed in the bottom pane of the screen. It is a representation of the table used by the `p4 protect` command, with exclusionary lines shown in red.

To edit the protections table, use the built-in editor or click ![edit](image) to edit the protections table as text.

To deny access to a specific portion of the depot to a user or group, use an exclusionary mapping: place a dash (-) in front of the path in the **Folder/File** field. Exclusionary mappings apply to all access levels, even though only one access level can be selected in the **Access Level** field.

The following table describes the fields in the protections table.

<table>
<thead>
<tr>
<th>Access Level</th>
<th>The permission being granted. Each permission level includes all lower-level permissions, except for <strong>review</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td>super</td>
<td>access to all commands and command options</td>
</tr>
<tr>
<td>admin</td>
<td>permits those administrative commands and command options that don’t affect server security</td>
</tr>
<tr>
<td>write</td>
<td>users can submit open files</td>
</tr>
<tr>
<td>open</td>
<td>users can open files for add, edit, delete, and integrate</td>
</tr>
<tr>
<td>read</td>
<td>users can sync, diff, and print files</td>
</tr>
<tr>
<td>list</td>
<td>users can see names but not contents of files; users can see all non-file related metadata (workspaces, users, changelists, jobs, etc.)</td>
</tr>
<tr>
<td>review</td>
<td>allows access to the <code>p4 review</code> command; intended for automated processes, implies <strong>read</strong> access.</td>
</tr>
</tbody>
</table>

| User/Group | Indicates whether this line applies to a Perforce user or group.                                              |
### Name
A Perforce user name or group name; can be wildcarded.

### Host
The IP address of a client host; can be wildcarded.

### Folder/File
The part of the depot to which access is being granted or denied. To deny access to a depot path, preface the path with a dash (-). Exclusionary mappings apply to all access levels, regardless of the access level specified in the first field.

### Comment
Optional description of table entry.

## Configuring Administration Tool Preferences

To configure settings for the Administration Tool, choose **Edit > Preferences...** (Windows) or **P4Admin > Preferences...** (Mac). The **Preferences** dialog includes the following configuration pages:

- **“Connections” on page 5**
- **“Logging” on page 6**
- **“Display” on page 6**
- **“Files” on page 6**
- **“Behavior” on page 7**
- **“Tools” on page 7**
- **“Editor” on page 8**
- **“Diff” on page 8**
- **“Applets” on page 9**

Click **Apply** to save your changes. Click **OK** to save your changes and exit the dialog.

### Connections

You can configure the following settings for connecting to Perforce servers:

#### When the application launches:

- **Restore all previously opened connections**: Do not prompt for connection settings; reconnect to the server to which you were connected during your last session.

#### Opening and closing connections:

- **Use IP-specific tickets when logging in**: Specifies whether your login ticket is restricted to the IP address from which you are connecting.
• **Automatically log off when closing a connection**: Specifies whether your ticket is invalidated when you log out.

### Logging

You can configure the following logging options:

**Log pane options:**

• **Show p4 reporting commands**: Specifies whether the log pane in the Administration Tool window displays all commands issued by the Administration Tool, including commands issued by the Administration Tool to obtain status information from the Perforce server.

**Logging to a file:**

• **Enable logging to file**: Logs Administration Tool activity to the specified file.
  
  • **Name**: Specifies the name and location of the log file.
  
  • **Size**: Specifies the maximum size of the log file.

### Display

You can configure the following Administration Tool display and localization options:

**Application:**

• **Show the What's New in P4V page after upgrading**: Display the What’s New page as a tab in the P4V window.

• **Dates**: Sets the date format used throughout the Administration Tool.
  
  • **Use OS format for dates**: Use the format that your operating system uses.
  
  • **Format dates using Perforce standard (yyyy/mm/dd hh:mm:ss)**

**Localization:**

• **Language used for application menus, labels, and dialogs (requires restart)**: Select language.

• **Set encoding for all connections to**: Sets the character encoding for connections to unicode-mode Perforce servers.
  
  If you do not set the encoding here, you are prompted to enter the character encoding every time you set up a connection to a unicode-mode Perforce server. The encoding that you set here does not affect server connections whose character encoding has already been set at connection. If you are unsure which setting to choose, consult your Perforce administrator.

### Files

You can configure the way the Administration Tool displays files and file icons:
• **Show Perforce filetype for files in the Workspace and Depot tree**: Toggles display of filetype in the tree panes.

• **Show revision information for files in the Workspace and Depot tree**: Toggles display of revision numbers in the tree panes.

• **Render thumbnails for Maya files**: Enables the Administration Tool to display thumbnail images of Maya media files.

• **File preview font**: Specifies the font that the Administration Tool uses to display files in the preview pane.

  Click **Show fixed sized fonts only** to limit the selection in the font drop-down to fixed-sized fonts.

### Behavior

You can configure the following Administration Tool user interface behaviors:

#### Prompts:

• **Warn before reverting files**: Specifies whether the Administration Tool displays a prompt before reverting files.

• **Prompt for changelist when checking out, adding, or deleting files**: Specifies whether the Administration Tool displays the "Choose changelist" dialog when you open files.

• **Prompt to get latest revision when checking out files that are out of date**

• **Prompt when connecting to a new Perforce Sandbox**: Specifies whether the Administration Tool displays a prompt before you connect to a new Perforce Sandbox.

#### Drag and drop:

• **Enable integration on directory-to-directory drag and drop**: Launches the Merge/Integrate dialog when you drop a folder on another folder.

• **Enable diff comparisons on file-to-file drag and drop**: Launches the Diff dialog when you drop a file on another file.

### Tools

You can configure the following Revision Graph and Time-Lapse View options:

#### Revision Graph:

• **Use software rendering for Revision Graph**: Enable only if your machine is having problems rendering Revision Graph output. For details, consult the Perforce Knowledge base.

• **Limit Revision Graph to ancestors and descendants**: Controls how much of a file's integration history is displayed.
• **Show branch history in Time-lapse View by default**: Specifies whether Time-lapse View displays the integration/merge history for the selected file by default. You can also toggle the display of integration history in Time-lapse View.

**Editor**

To associate file types with the applications you use to edit them:

1. Click **Add**.
2. Select a file extension from the drop-down list.
3. Enter or browse for the associated application.
4. (Optional) Select **Always use the selected application to open files of this type** to set the application as the default.
5. Click **Save**.

You can enter as many applications as you like for each extension. All of the applications will appear as options when you context-click a file in the Administration Tool and select **Open With**.

**Note**

Any application that you’ve used to open a file from the context menu in the Administration Tool appears by default as an associated application on the Editor page in the Administration Tool Preferences dialog, unless you remove it.

**Diff**

To set the default diff application, select one of the following:

1. **P4Merge**: Perforce's companion diff tool.
2. **Other application**: Browse to your preferred diff tool.

   To specify arguments for third-party diff applications, enter \%1 for the name of the first file and \%2 for the name of the second file in the **Arguments** field. Perforce replaces these placeholders with the actual filenames when calling the diff application.

To assign diff applications by file type:

1. Click **Add**.
2. Select a file extension from the drop-down list.
3. Enter or browse for the associated application.
4. Specify arguments for third-party diff applications in the **Arguments** field:

   Enter \%1 for the name of the first file and \%2 for the name of the second file. The Administration Tool replaces these placeholders with the actual filenames when calling the diff application.
5. Click **Save**.
The extension and associated application are displayed in the list of file type-application associations.

**Applets**

You can enable Perforce servers to serve applets that can run in the Administration Tool. In order for these applets to run in the Administration Tool, you must enable applets in your Administration Tool preferences. For more information about Perforce applets, see the *Perforce JavaScript API for Visual Tools Users Guide*.

To enable Perforce applets to run in the Administration Tool:

1. Select **Allow Perforce applets to run in P4Admin**.
2. Specify the Perforce servers from which you are willing to accept Perforce applets:
   - Enter the Perforce server name or host:port in the **Server** field.
   - Click **Add**.
3. Click **Advanced...** to specify the following settings:
   - **Save cookies from applets** (Click **Remove Cookies** to delete all applet-generated cookies).
   - **Allow applets to store data locally**
   - **Manually configure web proxy used by applets for internet access**: Enter the web proxy address and port.
Appendix

License Statements

Perforce software includes software developed by the University of California, Berkeley and its contributors. This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/).

Perforce software includes software from the Apache ZooKeeper project, developed by the Apache Software Foundation and its contributors. (http://zookeeper.apache.org/)