Managing Branch Mapping

In Perforce, a codeline is a set of related files for example, all the source code required to build your software product. Copying an edit from one file set to the other is called merging or copying. Copying a set of files to create a new codeline (or equivalent) is called making a branch or branching. Branching is performed using the Merge/Integrate feature. You can perform simple branches using a file mapping.

To ensure that complex branching is done in a controlled manner (for example, to prevent typographical errors when entering target directories or to make sure that complicated branches are performed correctly), you can create a branch mapping, which specifies the relationship between two codelines. When you branch, you can use the branch mapping instead of a file mapping. Branch mappings are displayed in the right pane on the Branch Mapping tab.

Note. Perforce Streams provide an alternative approach to managing codelines. For more information, see About Streams.

Work with branch mapping

To create a branch mapping, choose File>New>Branch Mapping... and enter the required information. To prevent the mapping from being changed by other users, check locked. To confine integration to closely related files, choose direct; to enable integration between distantly related files, choose indirect.

Use the View field to reflect the relationship between source and target codelines. For example, to create release 2 of Jam from the code in your main codeline, you might use the following view:

//depot/jam_proj/... //depot/jam_r2.0/...

To view a branch mapping, go to View>Branch Mappings or click the View branch mappings Branch mapping button in the toolbar. Use the Filter pane at the top of the Branch Mappings tab to search for mappings by owner and branch mapping name (or part of the name). Double-click a branch mapping to view it.

To change a branch mapping, double-click it in the Branch Mappings tab to open the Branch Mapping dialog. Click Edit to enter your changes.

To delete a branch mapping, click the mapping you want to delete, then select Edit>Delete Branch branchname.

To integrate using a branch mapping:

  1. Right click the files you want to integrate and choose Merge/Integrate... The Merge/Integrate dialog is displayed.
  2. Select User branch mapping as your Merge method.
  3. Browse for the branch mapping you want to use. Select the branch mapping and click OK.
  4. In the Target field, specify where you want the source files integrated. The target must be a path that contains some or all of the paths identified in the branch mapping. In other words, the target can be a subset of the path specified by the branch mapping.
  5. Specify other options as desired:
  6. To preview the results of the operation, click Preview.
  7. To integrate the files using the selected branch mapping, click Merge.