Structuring Streams

To set up streams for the first time, you must create a stream depot and create and populate a mainline stream.

To create a stream depot:

  1. Launch P4Admin (from P4V, choose Tools > Administration) and connect to the Perforce service as a user that has admin privilege.
  2. Choose File > New...> Depot, specify a name for the stream depot, and click OK. The Depot dialog is displayed.
  3. For Depot Type, choose stream.
  4. Click OK, and verify that your new stream depot is listed in the Depots tab.
To create the mainline stream:
  1. Launch P4V and connect to the Perforce service where you want your streams to reside.
  2. Choose File > New > Stream... The Stream dialog is displayed.
  3. Specify the name ("main" or "mainline" is a good descriptive choice), depot, and root folder. Omit parent (the mainline has none). For stream type, choose "mainline".
  4. Click OK to save your stream specification.
  5. Verify that your new mainline stream is displayed in the Streams tab. Note that the mainline stream is not displayed in the Depot tab until you populate it with files.

    For more information, see Creating Streams.

To populate your mainline stream:
  1. Copy the desired files and folders to the root folder of the workspace you just created (the mainline stream).
  2. In P4V, switch to the left-pane Workspace tab. Your files are displayed undecorated (that is, as plain file icons), which indicates that they are not under Perforce control.
  3. Context-click the top-level folder and choose Mark for Add... P4V displays the Select Pending Changelist dialog.
  4. Click OK. In the Pending Changelists tab, verify that your files are listed in the default changelist, decorated with a red plus sign.
  5. Context-click the default changelist and choose Submit... The Submit Changelist dialog is displayed.
  6. Enter a descriptive comment and click Submit.

Note: As an alternative, you can populate streams by integrating files from existing depot locations.

To verify that your files have been submitted, check the Log pane at the bottom of the screen and the left-pane Depot tab. If your submission succeeded, your files are listed in the mainline folder in your stream depot. Now you can branch the files in the mainline to development and release streams, edit files in those streams, and propagate changes among them.