P4VS User Guide (2020.1)

Defining a new Helix server connection

To define a new connection to a Helix server in Visual Studio:

  1. Open the Open Connection dialog. You can open this dialog the following ways:

    • Add a new project in Visual Studio in the New Project dialog. In this dialog, select the Add to source control using P4VS - Helix Plugin for Visual Studio check box; then click OK.

      The Open Connection dialog appears unless:

      • You did not select the check box.
      • You have set the connection settings in Tools > Options > Source Control > Helix Core - Connections to default to an option other than Show the Helix Core server Connection. In this case, P4VS attempts to connect without showing the Open Connection dialog.
      • You are already connected. In this case, P4VS does not attempt to connect and marks the new project for add.
    • Open a solution or project under Helix server source control in Visual Studio.

      The Open Connection dialog appears unless you’ve set the connection settings in Tools > Options > Source Control to default to the last Helix server connection or to connection settings defined in your environment variables.

    • Go to File > Open Connection to a Helix Core server in Visual Studio.
  2. Enter the server name and port number for this connection using host:port_number.

    If your Helix server is enabled for SSL (Secure Sockets Layer) encryption, use the following syntax: ssl:host:port_number

    Important

    If you attempt to connect to an SSL-enabled Helix server and you see a warning about an untrusted SSL connection or altered SSL fingerprint, contact your Helix server administrator before completing the connection.

  3. In the User field, enter your user name.

    • To browse for a particular user, click the Browse…​ button and select the user from that list.
    • To create a user, click the New…​ button and fill in the appropriate information.
  4. (Optional) In the Workspace field, specify the name of your client workspace.

    • To browse for a particular client workspace, click the Browse…​ button and select the workspace from that list.
    • To create a client workspace, click the New…​ button.
    • In the New Workspace dialog, enter a workspace name and click OK.
    • In the Workspace dialog, entered the required information.

    For more information on setting up client workspaces, see Managing workspace specifications.

  5. Click OK.

    P4VS connects to the specified Helix server. If the user you are connecting with does not have a p4 ticket, P4V prompts you for your password.

    Note

    If the server you are connecting to is configured with multi-factor authentication (MFA), you are prompted for another layer of verification. Depending on the setup, you may need to select a method of verification before you can enter your credentials.

    For more information, see p4 login2 in the Helix Core P4 Command Reference.

    Note

    If the server you are connecting to is configured for authentication with Helix Authentication Service, the Identity Provider (IdP) web page opens, prompting you for the credentials registered with your Identity Provider (IdP). For details, see https://github.com/perforce/helix-authentication-service or contact your Helix Core server administrator.

    Note

    If the server you are connecting to is configured for authentication with Helix SAML, the Helix SAML dialog opens, prompting you for the user name and password registered with your Identity Provider (IdP). For details, see "Helix SAML" in the in the Helix Core Server Administrator Guide or contact your Helix Core server administrator.